しま★りん.blog @ayurina

そこはかとない日常を綴るブログ

WordPress 4.0アップデート。TwentyTwelveテーマを更新したら、やっぱりエラーと言われた件。

time 2014/09/07

WordPress 4.0にアップデートして、テーマ「TwentyTwelve」も更新したら、やっぱりウェブマスターツールでupdatedが無いというエラーが出ました。

スクリーンショット 2014-09-07 3.10.55

いやテーマ更新されたら、治るかな、とちょっと期待していたのですが、治ってなかったです。残念。というわけで、functions.phpを書き換えました。

# diff twentytwelve/functions.php twentytwelve_ayurina/functions.php
375c375
< 	$date = sprintf( '<a href="%1$s" title="%2$s" rel="bookmark"><time class="entry-date" datetime="%3$s">%4$s</time></a>',
---
> 	$date = sprintf( '<a href="%1$s" title="%2$s" rel="bookmark"><time class="entry-date updated" datetime="%3$s">%4$s</time></a>',

ウェブマスターツールで、「ライブデータを確認」でエラーが出ていないことを確認しました。良かった。

これってでも、各テーマのほうで対応してくれないのでしょうか・・・うーん。

・・・・そしたらエラーになった(自爆)。

functions.phpをそのまま置いてしまうと「Cannot redeclare twentytwelve_setup()」と言われてエラーになる。これは親テーマのfunctions.phpを書き換えなければいけない。と。実は一瞬、うまく表示できたんだけど、これはキャッシュの成せる業?謎です。

sponsored link

down

コメントする






sponsored link

アーカイブ